질문을 삭제하지 말아주세요.!
 
1
0
-1

안녕하세요 라라벨 설치했는데요 

서버시작하고 

localhost:8000 접속하면 라라벨페이지 나오잖아요 궁금한건 localhost 에서 접속하고 싶은데 어떻게 해야하나요?

아무리 검색해도 안나오네요

부탁드립니다.

    CommentAdd your comment...

    5 answers

    1.  
      2
      1
      0
      Failed to listen on 127.0.0.1:80 (reason: Permission denied)

      라고 나왔다면 권한이 없어서 그런 것입니다.

      1024 이하의 포트는 root 권한으로만 제어가 가능하다는 것 같네요.

      따라서 Chunki 님이 답변해주신 커맨드 앞에 sudo 를 붙여주시면 될 것입니다.

      sudo php artisan serve --port=80
      1. ddammo55

        [Tue Feb 21 00:30:02 2017] Failed to listen on 127.0.0.1:80 (reason: Address already in use)

        요번에는 이렇게 나옵니다 centos7입니다,

      2. Chunki

        이미 80 포트를 사용하고 있는 프로세스가 있다는 메시지입니다.(Address already in use) 아마 시스템에 이미 아파치가 실행되어 있는 것으로 보이는데, 실습용 환경이라면 아파치를 종료하고 위의 커맨드를 실행하시면 될 것 같습니다.

        제가 CentOS 7을 사용하지 않아서 확인은 못해봤습니다만, 아파치를 다른 방식으로 설치하신 것이 아니라면 다음과 같이 종료가 가능한 것 같습니다.(root로 실행하거나 앞에 sudo를 붙이셔아합니다.)

        systemctl stop httpd.service

        http://www.linuxcommands.info/linux-systemctl-command/#stop_service

      3. ddammo55

        댓글 감사합니다.

        어제 새벽에 아파치설정 잘못 건드려서 해결해야합니다. ㅜㅜ

        아파치가 제대로 작동되면 다시 해보겠습니다.

        점심 맛있게 드세요~

        https://www.phpschool.com/gnuboard4/bbs/board.php?bo_table=qna_install&wr_id=117255&page=1

      CommentAdd your comment...
    2.  
      1
      0
      -1


        CommentAdd your comment...
      1.  
        1
        0
        -1

        춘기님 말씀대로 httpd(Centos용 Apache2)가 이미 80번 포트를 점유하고 있습니다.


        두 가지 방법이 있는데

        1. httpd 서비스를 종료하고 php /path/to/your-laravel-project/artisan serve 를 이용하는 방법
        2. 시스템에서 이미 돌고 있는 httpd를 이용하는 방법

        입니다.


        1번 방법은 춘기님이 설명해 주셨습니다. 그런데, OS 보안 설정 때문에, artisan 명령으로 실행한 PHP 로컬 웹 서버가 80번 포트를 사용할 수 있는지는 모르겠습니다.


        2번 방법은 다음 절차대로 따라 하시면 됩니다.


        브라우저에서 http://localhost 를 열어 httpd가 정상 작동하고 있는지 확인합니다. 웹 서버의 웰컴 페이지 같은게 나올 수도, 경우에 따라 안 나올 수도 있습니다.


        기본 사이트를 제거합니다.

        # httpd의 document_root가 /var/www/html, 설정 파일은 /etc/httpd/sites-enabled/default.conf라고 가정합니다.
        
        
        $ mv /etc/httpd/sites-enabled/default.conf /etc/httpd/sites-enabled/default.conf.bak

        새 사이트를 추가합니다.

        # 라라벨 프로젝트는 /path/to/your-laravel-project 에 위치하고 있다고 가정합니다.
        
        
        $ vi /etc/httpd/sites-available/laravel.conf # 아래 내용을 파일에 붙여넣고 저장!
        <VirtualHost *:80>
            ServerName localhost
            DocumentRoot /path/to/your-laravel-project/public
        
            <IfModule mod_dir.c>
            	DirectoryIndex index.php
        	</IfModule>
        	
            <Directory "/var/www/html/public">
        	    Options Indexes FollowSymLinks
        	    AllowOverride All
                # for 2.2
                <IfModule !mod_authz_core.c>
                    Order deny,allow
                    Allow from all
                </IfModule>
        
                # for 2.4
                <IfModule mod_authz_core.c>
                    Require all granted
                </IfModule>
        	</Directory>
        </VirtualHost>
        
        
        $ ln -s /etc/httpd/sites-available/laravel.conf /etc/httpd/sites-enabled/laravel.conf
        
        

        httpd 를 재시작합니다.

        $ sudo systemctl restart httpd.service

        브라우저에서 http://localhost 를 열어 라라벨 welcome 페이지 또는 본인이 작성한 코드가 나오는 지 확인합니다.


        문제가 생기면 이 문서를 더 참고하세요. https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-on-centos-7

        1. ddammo55

          댓글 감사드립니다

          퇴근 후 집에가서 열심히 해보겠습니다.

          라라벨 책은 샀는데 3주째 리눅스 세팅하느라 지연되고 있네요...

          제가 잘 할 수 있을지 걱정입니다. 리눅스도 처음 만져보고 프레임웍도 처음입니다.

          그래도 열심히 해보렵니다^^

        CommentAdd your comment...
      2.  
        1
        0
        -1

          CommentAdd your comment...
        1.  
          1
          0
          -1

          라라벨에서 PHP 내장 웹서버를 실행했을 때에 웹 브라우저에서 http://localhost:8000 대신에 http://localhost 로 접속해서 확인하는 방법에 대한 질문인 것으로 이해했는데요.

          HTTP 기본 포트인 80을 사용하면 브라우저에서 포트 번호를 명시할 필요가 없기 때문에 아래와 같이 --port 옵션을 사용하시면 됩니다.

          php artisan serve --port=80
          1. ddammo55

            알려주신데로 했는데 이렇게 메세지가 나옵니다.

            [Mon Feb 20 22:58:18 2017] Failed to listen on 127.0.0.1:80 (reason: Permission denied)


          CommentAdd your comment...