질문을 삭제하지 말아주세요.!
 
1
0
-1

실제 우분투 서버에 라라벨을 설치하고자합니다

 

현재는 아파치와 php 5.5.9가 서버에 설치되어있는데 몇몇분들은 5.6 , 5.3 이상에서 설치가 된다고하는데

 

어느게 맞는지 궁금합니다

 

마지막으로 현재 아파치와 php가 설치가되어있다면 composer만 설치한다면 라라벨을 쓸수있는건가요?

    CommentAdd your comment...

    1 answer

    1.  
      3
      2
      1

      정수님이 번역하신 라라벨 공식 문서(https://laravel.kr/docs/5.2/installation) 를 보면 PHP 5.5.9 이상이면 되며 필요한 php extension 이 몇 개 있습니다.

       

      제가 우분투용으로 "라라벨 배포 환경 구성하기 위해 nginx, php7, mysql 5.7, redis" 설치 스크립트를 정리했으니 참고 하시기 바랍니다.

       

      아파치를 사용할 경우 mod_php 를 설치하면 되는데 nginx + php_fpm 환경을 권장합니다.

      1. 이태희

        혹시 이파치로 하더라도 우분투서버에 깃허브 설치해야  컴포저쓸수있나요??

      2. 이태희

        현재 저는 아파치를 일단 사용하려고하는데

        php extension이 갖추었다면  컴포저 전역 설치관련 명령어 몇개를 입력해야 라라벨을 본격적으로 할수있는거죠?

         

        ## composer 전역 설치
         curl -O -sS https://getcomposer.org/installer
         sudo php installer --install-dir=/usr/local/bin
         sudo ln -s /usr/local/bin/composer.phar /usr/local/bin/composer
      3. 안정수

        라라벨을 설치하려면 composer 가 필요한데 이러한 composer 는 말씀하신것처럼 직접 설치하신 후에 사용하시면 됩니다. 다만 꼭 전역으로 설치는 안하셔도 됩니다. 

      CommentAdd your comment...