Confluence 에 심각한 보안 취약점이 발견되었으니 사용자분들은 업그레이드 하세요.!
 
1
0
-1

쿼리 빌더로 쿼리를 작성했는데, 로컬의 유닛테스트에서는 정상적으로 동작하는 것을 확인했습니다.

그런데, 서버에 올리고 호출하니 에러가 나네요.


Parse error: syntax error, unexpected '?', expecting variable (T_VARIABLE)

in PDOConnection.php line 24


이런 에러인데, 뭐가 문제일까요?

로컬 php: 7.1.23

서버 php: 7.0.0p1

이 차이 외에는 동일한데, php 버전 문제일까요?

어떻게 해결해야 할지...

    CommentAdd your comment...

    1 answer

    1.  
      1
      0
      -1

      php 버전 문제였네요. php를 7.3으로 올리니 문제가 해결됐습니다.

        CommentAdd your comment...