질문을 삭제하지 말아주세요.!
 
1
0
-1

기존에 5.6 버전으로 사용하고 있었고 이번에 새로운 서비스를 하기 위해 php7.0 docker 사용해서 하려고 합니다.

둘다 설치는 됐구요.

composer install를 하는데 자꾸

Problem 1
- This package requires php >=7.0.0 but your PHP version (5.6.30) does not satisfy that requirement.

이러한 에러가 나타납니다.


두 버전 모두 사용할 수 있는 방법이 있을까요?

    CommentAdd your comment...

    1 answer

    1.  
      1
      0
      -1

      홈브루로 설치했다면 쉽게 전환할 수 있습니다. 실행 환경을 격리하려면 5.6 도커 컨테이너, 7.0 도커 컨테이너로 각각 실행 환경을 만드실 것을 추천드립니다.


      $ brew list | grep php
      # php70
      # php71
      # ...
      
      $ php --version
      # PHP 7.1.2 (cli) (built: Feb 17 2017 10:52:17) ( NTS )
      
      $ brew unlink php71
      # Unlinking /usr/local/Cellar/php71/7.1.2_13... 17 symlinks removed
      
      $ brew link php70
      # Linking /usr/local/Cellar/php70/7.0.13_6... 17 symlinks created
      
      $ php --version
      # PHP 7.0.22 (cli) (built: Aug  7 2017 14:07:27) ( NTS )
      1. lzao

        답변 감사합니다.

        php 5.6은 mac을 사용하고 있어서 따로 brew로 설치하진 않았는데

        brew로 설치해야지만 가능한건가요?

        아니면 5.6 docker를 새로 만들어야 하나요?

      2. 안민섭

        구성하신 환경이 php5.6은 mac에 설치되어 있고, php7은 docker 로 구성하신것 같은데요.

        사용하시려는 패키지가 말씀하신 '새로운 서비스'에서 사용하실 목적이시라면,

        php7 docker 내에서 실행하는것이 방법일것 같습니다.

        mac의 기본 php 를 쓰시기 보다는 위 답변처럼 각 version별 docker 환경을 추천드립니다.

      CommentAdd your comment...