Confluence 에 심각한 보안 취약점이 발견되었으니 사용자분들은 업그레이드 하세요.!
 
1
0
-1

서버에 아래처럼

  • OpenSSL PHP Extension
  • PDO PHP Extension
  • Mbstring PHP Extension
  • Tokenizer PHP Extension
  • XML PHP Extension
  • Ctype PHP Extension
  • JSON PHP Extension


설치해야하는거같은데,, 어떻게 설치해야할지모르겠고, 혹시나 있는건데 또 중복설치되는건 아닌가 싶구영..


바로
composer global require "laravel/installer"

를 사용하니


the requested PHP extension zip is missing from your system.
composer global require "laravel/installer"


요런 에러도 뜨구요...


원래 이렇게 설치가 어려운가요 ㅠㅠ


옛날에 코드이그나이터 몇번사용해을때는 폴더를 ftp를 이용하여 업로드하니까 잘되더라구여...


라라벨은 첫 시작부터어렵네요 ㅠ



좋은 팁이나, 간편한 설치방법은없을까요?ㅠㅠㅠ


요건 다 설치해야하나요? 서버는 잘몰라서 어떻게 설치하는지도 잘모르겠네요 ㅠ

  • OpenSSL PHP Extension
  • PDO PHP Extension
  • Mbstring PHP Extension
  • Tokenizer PHP Extension
  • XML PHP Extension
  • Ctype PHP Extension
  • JSON PHP Extension
    CommentAdd your comment...

    2 answers

    1.  
      1
      0
      -1

      자답입니다

      yum install php72-php-zip

      yum install --enablerepo=remi,remi-php72 php-pecl-zip

      위 명령어로 설치했더니 되었습니다 ㅠ

        CommentAdd your comment...
      1.  
        1
        0
        -1

        php 확장들입니다. 서버 환경이 어떤지에 따라 설치나 활성화 방법이 달라요. 서버 환경이 윈도우인지 리눅스인지, 리눅스면 어떤 os 인지 설명이 필요합니다. 

        1. 리눅스 centos6입니당 (php7 )

          XXXXXX php extension는 어떻게 설치해야하나요? 

        2. Sangseng
          centos 에서 패키지는 yum 으로 관리하면 됩니다. 


          yum install php-common php-xml php-mbstring php-json php-zip


          위 명령어처럼 설치하면 되고요. 그 외 필요한 패키지를 yum search "패키지명" 으로 검색해서 해당 패키지를 설치할 수 있습니다.  CLI 명령어는 https://access.redhat.com/sites/default/files/attachments/rh_yum_cheatsheet_1214_jcs_print-1.pdf  참고하세요. 


          그리고 위 확장들이 제대로 활성화되어 있는지 php.ini 파일에서 확인하셔야 하고, 파일 위치는 php --ini 로 확인할 수 있을 겁니다. 

        3. 답변감사합니다! 저런 방법이 있었네요..배울게 끝이없네요..

        CommentAdd your comment...